OPEN_ROBOT_ZigBee_Class_Library Namespace

OPEN-ROBOT ZigBee Functions Documented Class Library
OPEN_ROBOT_ZigBee_Class_Library Namespace
CollapseAll image

[Missing namespace summary documentation for N:OPEN_ROBOT_ZigBee_Class_Library]

Classes

Icon | Type | Description
public class | OPEN_ROBOT_ZigBee_Functions | OPEN_ROBOT Functions Class. Contains all the necessary methods to communicate with the OPEN-ROBOT Robot.

Structures

Icon | Type | Description
public structure | OPEN_ROBOT_Parameters | OPEN_ROBOT Parameter Structure. Contains all OPEN-ROBOT sensors and internal parameters.

Send comments on this topic to abe@abotics.com

Copyright 2008 Abe Howell's Robotics.


OPEN_ROBOT_ZigBee_Functions Class

OPEN_ROBOT_ZigBee_Functions Class
CollapseAll image DropDown image

OPEN_ROBOT Functions Class. Contains all the necessary methods to communicate with the OPEN-ROBOT Robot.

Namespace: OPEN_ROBOT_ZigBee_Class_Library
Assembly: OPEN_ROBOT_ZigBee_Functions Version: 1.0.0.0 (OPEN_ROBOT_ZigBee_Functions)

Syntax

Visual Basic (Declaration)
Public Class OPEN_ROBOT_ZigBee_Functions
C#
public class OPEN_ROBOT_ZigBee_Functions
C++
public ref class OPEN_ROBOT_ZigBee_Functions

Inheritance Hierarchy

Object
OPEN_ROBOT_ZigBee_Class_Library.OPEN_ROBOT_ZigBee_Functions


OPEN_ROBOT_ZigBee_Functions Constructor

OPEN_ROBOT_ZigBee_Functions Constructor
CollapseAll image DropDown image

OPEN_ROBOT Functions Class Constructor.

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public OPEN_ROBOT_ZigBee_Functions ()
C++
public:
OPEN_ROBOT_ZigBee_Functions ()


Close_Serial_Port Method

Close_Serial_Port Method
CollapseAll image DropDown image

Function to close serial port.

Syntax

Visual Basic (Declaration)
Public Function Close_Serial_Port As String
C#
public string Close_Serial_Port ()
C++
public:
String^ Close_Serial_Port ()

Return Value

String. OK is returned when successful, otherwise error is returned.


Enter_XBee_Command_Mode Method (timeOut, numRetries)

Enter_XBee_Command_Mode Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to Enter XBee Command Mode.

Syntax

Visual Basic (Declaration)
Public Function Enter_XBee_Command_Mode ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Enter_XBee_Command_Mode (
    int timeOut,
    int numRetries
)
C++
public:
String^ Enter_XBee_Command_Mode (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from XBee board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Exit_XBee_Command_Mode Method (timeOut, numRetries)

Exit_XBee_Command_Mode Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to Exit XBee Command Mode.

Syntax

Visual Basic (Declaration)
Public Function Exit_XBee_Command_Mode ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Exit_XBee_Command_Mode (
    int timeOut,
    int numRetries
)
C++
public:
String^ Exit_XBee_Command_Mode (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from XBee board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Find_RFID_Tag Method (timeOut, numRetries)

Find_RFID_Tag Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to find in-range RFID tags. Robot will search for in-range tags and stop when a tag is located.

Syntax

Visual Basic (Declaration)
Public Function Find_RFID_Tag ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Find_RFID_Tag (
    int timeOut,
    int numRetries
)
C++
public:
String^ Find_RFID_Tag (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Get_Port_List Method

Get_Port_List Method
CollapseAll image DropDown image

Function to return a list of available ports.

Syntax

Visual Basic (Declaration)
Public Function Get_Port_List As String()
C#
public string[] Get_Port_List ()
C++
public:
array<String^>^ Get_Port_List ()

Return Value

String array of available port names.


Halt_Agent Method (timeOut, numRetries)

Halt_Agent Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to stop the agent immediately.

Syntax

Visual Basic (Declaration)
Public Function Halt_Agent ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Halt_Agent (
    int timeOut,
    int numRetries
)
C++
public:
String^ Halt_Agent (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Move_To_Position Method (leftWheel, rightWheel, timeOut, numRetries)

Move_To_Position Method (leftWheel, rightWheel, timeOut, numRetries)
CollapseAll image DropDown image

Function to move robot using position control.

Syntax

Visual Basic (Declaration)
Public Function Move_To_Position ( _
    leftWheel As Integer, _
    rightWheel As Integer, _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Move_To_Position (
    int leftWheel,
    int rightWheel,
    int timeOut,
    int numRetries
)
C++
public:
String^ Move_To_Position (
    int leftWheel,
    int rightWheel,
    int timeOut,
    int numRetries
)

Parameters

leftWheel (Int32)
Number of left wheel encoder ticks. Valid range is -500 to 500.
rightWheel (Int32)
Number of right wheel encoder ticks. Valid range is -500 to 500.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Open_Serial_Port Method (strPort, baudRate)

Open_Serial_Port Method (strPort, baudRate)
CollapseAll image DropDown image

Function to open serial port.

Syntax

Visual Basic (Declaration)
Public Function Open_Serial_Port ( _
    strPort As String, _
    baudRate As Integer _
) As String
C#
public string Open_Serial_Port (
    string strPort,
    int baudRate
)
C++
public:
String^ Open_Serial_Port (
    String^ strPort,
    int baudRate
)

Parameters

strPort (String)
Port name. COM1, COM2, COM3, etc...
baudRate (Int32)
Baud rate. 1200, 2400, 4800, 9600, 19200, etc...

Return Value

String. OK is returned when successful, otherwise error is returned.


Refresh_16Bit_XBee_Destination_Address_Low Method (timeOut, numRetries)

Refresh_16Bit_XBee_Destination_Address_Low Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to refresh the 16-Bit XBee Destination Address Low.

Syntax

Visual Basic (Declaration)
Public Function Refresh_16Bit_XBee_Destination_Address_Low ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Refresh_16Bit_XBee_Destination_Address_Low (
    int timeOut,
    int numRetries
)
C++
public:
String^ Refresh_16Bit_XBee_Destination_Address_Low (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from XBee board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Refresh_AD_Light_Reflex_Levels Method (timeOut, numRetries)

Refresh_AD_Light_Reflex_Levels Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to refresh ad/light sensor reflex level.

Syntax

Visual Basic (Declaration)
Public Function Refresh_AD_Light_Reflex_Levels ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Refresh_AD_Light_Reflex_Levels (
    int timeOut,
    int numRetries
)
C++
public:
String^ Refresh_AD_Light_Reflex_Levels (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Refresh_AD_Readings Method (timeOut, numRetries)

Refresh_AD_Readings Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to update the AD Readings.

Syntax

Visual Basic (Declaration)
Public Function Refresh_AD_Readings ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Refresh_AD_Readings (
    int timeOut,
    int numRetries
)
C++
public:
String^ Refresh_AD_Readings (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Refresh_Digital_Pin_Reading Method (intPinNum, timeOut, numRetries)

Refresh_Digital_Pin_Reading Method (intPinNum, timeOut, numRetries)
CollapseAll image DropDown image

Function to refresh pin reading.

Syntax

Visual Basic (Declaration)
Public Function Refresh_Digital_Pin_Reading ( _
    intPinNum As Integer, _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Refresh_Digital_Pin_Reading (
    int intPinNum,
    int timeOut,
    int numRetries
)
C++
public:
String^ Refresh_Digital_Pin_Reading (
    int intPinNum,
    int timeOut,
    int numRetries
)

Parameters

intPinNum (Int32)
Pin number. Valid range is 0 to 7.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Refresh_Encoder_Readings Method (timeOut, numRetries)

Refresh_Encoder_Readings Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to refresh the wheel encoder readings.

Syntax

Visual Basic (Declaration)
Public Function Refresh_Encoder_Readings ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Refresh_Encoder_Readings (
    int timeOut,
    int numRetries
)
C++
public:
String^ Refresh_Encoder_Readings (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Refresh_Firmware_Info Method (timeOut, numRetries)

Refresh_Firmware_Info Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to refresh firmware information for the PIC18F4520.

Syntax

Visual Basic (Declaration)
Public Function Refresh_Firmware_Info ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Refresh_Firmware_Info (
    int timeOut,
    int numRetries
)
C++
public:
String^ Refresh_Firmware_Info (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Refresh_Move_Complete Method (timeOut, numRetries)

Refresh_Move_Complete Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to refresh move complete.

Syntax

Visual Basic (Declaration)
Public Function Refresh_Move_Complete ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Refresh_Move_Complete (
    int timeOut,
    int numRetries
)
C++
public:
String^ Refresh_Move_Complete (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Refresh_Position_PID_Gains Method (timeOut, numRetries)

Refresh_Position_PID_Gains Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to refresh the position pid gains.

Syntax

Visual Basic (Declaration)
Public Function Refresh_Position_PID_Gains ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Refresh_Position_PID_Gains (
    int timeOut,
    int numRetries
)
C++
public:
String^ Refresh_Position_PID_Gains (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Refresh_PWM_Offsets Method (timeOut, numRetries)

Refresh_PWM_Offsets Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to refresh the Left and Right PWM Motor Offset Parameters.

Syntax

Visual Basic (Declaration)
Public Function Refresh_PWM_Offsets ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Refresh_PWM_Offsets (
    int timeOut,
    int numRetries
)
C++
public:
String^ Refresh_PWM_Offsets (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Refresh_Reflex_Triggered Method (timeOut, numRetries)

Refresh_Reflex_Triggered Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to refresh reflex triggered.

Syntax

Visual Basic (Declaration)
Public Function Refresh_Reflex_Triggered ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Refresh_Reflex_Triggered (
    int timeOut,
    int numRetries
)
C++
public:
String^ Refresh_Reflex_Triggered (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Refresh_RFID_Reading Method (timeOut, numRetries)

Refresh_RFID_Reading Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to Update RFID Reading.

Syntax

Visual Basic (Declaration)
Public Function Refresh_RFID_Reading ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Refresh_RFID_Reading (
    int timeOut,
    int numRetries
)
C++
public:
String^ Refresh_RFID_Reading (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Refresh_RFID_Tag_Found Method (timeOut, numRetries)

Refresh_RFID_Tag_Found Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to Update RFID Tag Found. Used in conjunction with Find_RFID_Tag function. Checks to see if a tag has been located.

Syntax

Visual Basic (Declaration)
Public Function Refresh_RFID_Tag_Found ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Refresh_RFID_Tag_Found (
    int timeOut,
    int numRetries
)
C++
public:
String^ Refresh_RFID_Tag_Found (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Refresh_Velocity_PID_Gains Method (timeOut, numRetries)

Refresh_Velocity_PID_Gains Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to refresh the velocity pid gains.

Syntax

Visual Basic (Declaration)
Public Function Refresh_Velocity_PID_Gains ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Refresh_Velocity_PID_Gains (
    int timeOut,
    int numRetries
)
C++
public:
String^ Refresh_Velocity_PID_Gains (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Refresh_Velocity_Readings Method (timeOut, numRetries)

Refresh_Velocity_Readings Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to update the wheel velocity readings.

Syntax

Visual Basic (Declaration)
Public Function Refresh_Velocity_Readings ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Refresh_Velocity_Readings (
    int timeOut,
    int numRetries
)
C++
public:
String^ Refresh_Velocity_Readings (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Reset_RFID_Module Method (timeOut, numRetries)

Reset_RFID_Module Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to reset the RFID module.

Syntax

Visual Basic (Declaration)
Public Function Reset_RFID_Module ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Reset_RFID_Module (
    int timeOut,
    int numRetries
)
C++
public:
String^ Reset_RFID_Module (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Reset_Sensor_Reflex_Trigger Method (timeOut, numRetries)

Reset_Sensor_Reflex_Trigger Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to reset sensor reflex trigger.

Syntax

Visual Basic (Declaration)
Public Function Reset_Sensor_Reflex_Trigger ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Reset_Sensor_Reflex_Trigger (
    int timeOut,
    int numRetries
)
C++
public:
String^ Reset_Sensor_Reflex_Trigger (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


ROBOT_Parameters Field

ROBOT_Parameters Field
CollapseAll image DropDown image

Declare an instance of the OPEN-ROBOT_Parameters Struct.

Syntax

Visual Basic (Declaration)
Public ROBOT_Parameters As OPEN_ROBOT_Parameters
C#
public OPEN_ROBOT_ZigBee_Functions.OPEN_ROBOT_Parameters ROBOT_Parameters
C++
public:
OPEN_ROBOT_Parameters ROBOT_Parameters


Save_Parameters_To_EEPROM Method (timeOut, numRetries)

Save_Parameters_To_EEPROM Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to save ABE parameters to EEPROM.

Syntax

Visual Basic (Declaration)
Public Function Save_Parameters_To_EEPROM ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Save_Parameters_To_EEPROM (
    int timeOut,
    int numRetries
)
C++
public:
String^ Save_Parameters_To_EEPROM (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Send_Data Method (strData, bSendCR, bUseStartChar, chrStartChar, timeOut, numRetries)

Send_Data Method (strData, bSendCR, bUseStartChar, chrStartChar, timeOut, numRetries)
CollapseAll image DropDown image

Function to Send Data Out the Serial Port.

Syntax

Visual Basic (Declaration)
Public Function Send_Data ( _
    strData As String, _
    bSendCR As Boolean, _
    bUseStartChar As Boolean, _
    chrStartChar As Char, _
    timeOut As Integer, _
    numRetries As Integer _
) As String()
C#
public string[] Send_Data (
    string strData,
    bool bSendCR,
    bool bUseStartChar,
    char chrStartChar,
    int timeOut,
    int numRetries
)
C++
public:
array<String^>^ Send_Data (
    String^ strData,
    bool bSendCR,
    bool bUseStartChar,
    wchar_t chrStartChar,
    int timeOut,
    int numRetries
)

Parameters

strData (String)
Serial data.
bSendCR (Boolean)
Command character.
bUseStartChar (Boolean)
Determines whether to use a start character.
chrStartChar (Char)
First returned character.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String array. OK is returned in the first array position when successful, otherwise error is returned. String from ABE board is contained within second array position.


Send_Data_Hex_Upload Method (strData, endChar, timeOut, numRetries)

Send_Data_Hex_Upload Method (strData, endChar, timeOut, numRetries)
CollapseAll image DropDown image

Function to Send Data Out the Serial Port.

Syntax

Visual Basic (Declaration)
Public Function Send_Data_Hex_Upload ( _
    strData As String, _
    endChar As Char, _
    timeOut As Integer, _
    numRetries As Integer _
) As String()
C#
public string[] Send_Data_Hex_Upload (
    string strData,
    char endChar,
    int timeOut,
    int numRetries
)
C++
public:
array<String^>^ Send_Data_Hex_Upload (
    String^ strData,
    wchar_t endChar,
    int timeOut,
    int numRetries
)

Parameters

strData (String)
Serial data.
endChar (Char)
End returned character.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.

Return Value

String array. OK is returned in the first array position when successful, otherwise error is returned. String from ABE board is contained within second array position.


Set_16Bit_XBee_Destination_Low_Address Method (intAddress, timeOut, numRetries)

Set_16Bit_XBee_Destination_Low_Address Method (intAddress, timeOut, numRetries)
CollapseAll image DropDown image

Function to Set XBee Destination Low Address using 16-Bit Addressing.

Syntax

Visual Basic (Declaration)
Public Function Set_16Bit_XBee_Destination_Low_Address ( _
    intAddress As Short, _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Set_16Bit_XBee_Destination_Low_Address (
    short intAddress,
    int timeOut,
    int numRetries
)
C++
public:
String^ Set_16Bit_XBee_Destination_Low_Address (
    short intAddress,
    int timeOut,
    int numRetries
)

Parameters

intAddress (Int16)
16-Bit XBee Address Low.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from XBee board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Set_AD_Reflex_Level Method (reflexLevel, timeOut, numRetries)

Set_AD_Reflex_Level Method (reflexLevel, timeOut, numRetries)
CollapseAll image DropDown image

Function to set the AD reflex level.

Syntax

Visual Basic (Declaration)
Public Function Set_AD_Reflex_Level ( _
    reflexLevel As Integer, _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Set_AD_Reflex_Level (
    int reflexLevel,
    int timeOut,
    int numRetries
)
C++
public:
String^ Set_AD_Reflex_Level (
    int reflexLevel,
    int timeOut,
    int numRetries
)

Parameters

reflexLevel (Int32)
AD reflex level. Valid range is 0 to 255.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Set_Closed_Loop_Velocity Method (leftWheelVelocity, rightWheelVelocity, timeOut, numRetries)

Set_Closed_Loop_Velocity Method (leftWheelVelocity, rightWheelVelocity, timeOut, numRetries)
CollapseAll image DropDown image

Function to set Closed loop wheel velocity.

Syntax

Visual Basic (Declaration)
Public Function Set_Closed_Loop_Velocity ( _
    leftWheelVelocity As Integer, _
    rightWheelVelocity As Integer, _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Set_Closed_Loop_Velocity (
    int leftWheelVelocity,
    int rightWheelVelocity,
    int timeOut,
    int numRetries
)
C++
public:
String^ Set_Closed_Loop_Velocity (
    int leftWheelVelocity,
    int rightWheelVelocity,
    int timeOut,
    int numRetries
)

Parameters

leftWheelVelocity (Int32)
Left wheel velocity. Valid range is -60 to 60 tenths of an inch per second.
rightWheelVelocity (Int32)
Right wheel velocity. Valid range is -60 to 60 tenths of an inch per second.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Set_Digital_Pin_High Method (pinNum, timeOut, numRetries)

Set_Digital_Pin_High Method (pinNum, timeOut, numRetries)
CollapseAll image DropDown image

Function to set digital pin high.

Syntax

Visual Basic (Declaration)
Public Function Set_Digital_Pin_High ( _
    pinNum As Integer, _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Set_Digital_Pin_High (
    int pinNum,
    int timeOut,
    int numRetries
)
C++
public:
String^ Set_Digital_Pin_High (
    int pinNum,
    int timeOut,
    int numRetries
)

Parameters

pinNum (Int32)
Digital pin number. Valid range is 0 to 7.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Set_Digital_Pin_Low Method (pinNum, timeOut, numRetries)

Set_Digital_Pin_Low Method (pinNum, timeOut, numRetries)
CollapseAll image DropDown image

Function to set digital pin low.

Syntax

Visual Basic (Declaration)
Public Function Set_Digital_Pin_Low ( _
    pinNum As Integer, _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Set_Digital_Pin_Low (
    int pinNum,
    int timeOut,
    int numRetries
)
C++
public:
String^ Set_Digital_Pin_Low (
    int pinNum,
    int timeOut,
    int numRetries
)

Parameters

pinNum (Int32)
Pin number. Valid range is 0 to 7.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Set_Light_Reflex_Level Method (reflexLevel, timeOut, numRetries)

Set_Light_Reflex_Level Method (reflexLevel, timeOut, numRetries)
CollapseAll image DropDown image

Function to set light reflex level.

Syntax

Visual Basic (Declaration)
Public Function Set_Light_Reflex_Level ( _
    reflexLevel As Integer, _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Set_Light_Reflex_Level (
    int reflexLevel,
    int timeOut,
    int numRetries
)
C++
public:
String^ Set_Light_Reflex_Level (
    int reflexLevel,
    int timeOut,
    int numRetries
)

Parameters

reflexLevel (Int32)
Light reflex level. Valid range is 0 to 255.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Set_Open_Loop_Velocity Method (leftWheelVelocity, rightWheelVelocity, timeOut, numRetries)

Set_Open_Loop_Velocity Method (leftWheelVelocity, rightWheelVelocity, timeOut, numRetries)
CollapseAll image DropDown image

Function to set open loop wheel velocity.

Syntax

Visual Basic (Declaration)
Public Function Set_Open_Loop_Velocity ( _
    leftWheelVelocity As Integer, _
    rightWheelVelocity As Integer, _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Set_Open_Loop_Velocity (
    int leftWheelVelocity,
    int rightWheelVelocity,
    int timeOut,
    int numRetries
)
C++
public:
String^ Set_Open_Loop_Velocity (
    int leftWheelVelocity,
    int rightWheelVelocity,
    int timeOut,
    int numRetries
)

Parameters

leftWheelVelocity (Int32)
Left wheel velocity. Valid range is -90 to 90.
rightWheelVelocity (Int32)
Right wheel velocity. Valid range is -90 to 90.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Set_Position_PID_Gains Method (Kp, Ki, Kd, timeOut, numRetries)

Set_Position_PID_Gains Method (Kp, Ki, Kd, timeOut, numRetries)
CollapseAll image DropDown image

Function to set the position pid gains.

Syntax

Visual Basic (Declaration)
Public Function Set_Position_PID_Gains ( _
    Kp As Integer, _
    Ki As Integer, _
    Kd As Integer, _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Set_Position_PID_Gains (
    int Kp,
    int Ki,
    int Kd,
    int timeOut,
    int numRetries
)
C++
public:
String^ Set_Position_PID_Gains (
    int Kp,
    int Ki,
    int Kd,
    int timeOut,
    int numRetries
)

Parameters

Kp (Int32)
Proportional gain. Valid range is 0 to 255.
Ki (Int32)
Integral gain. Valid range is 0 to 255.
Kd (Int32)
Derivative gain. Valid range is 0 to 255.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Set_PWM_Offset Method (pwm_offset, leftWheel, timeOut, numRetries)

Set_PWM_Offset Method (pwm_offset, leftWheel, timeOut, numRetries)
CollapseAll image DropDown image

Function to set the PWM Motor Offset.

Syntax

Visual Basic (Declaration)
Public Function Set_PWM_Offset ( _
    pwm_offset As Integer, _
    leftWheel As Boolean, _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Set_PWM_Offset (
    int pwm_offset,
    bool leftWheel,
    int timeOut,
    int numRetries
)
C++
public:
String^ Set_PWM_Offset (
    int pwm_offset,
    bool leftWheel,
    int timeOut,
    int numRetries
)

Parameters

pwm_offset (Int32)
PWM Motor Offset Parameter.
leftWheel (Boolean)
Set to true to adjust left wheel pwm, otherwise false for the right wheel.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Set_Sensor_Reflexes Method (strBitString, timeOut, numRetries)

Set_Sensor_Reflexes Method (strBitString, timeOut, numRetries)
CollapseAll image DropDown image

Function to set sensor reflexes.

Syntax

Visual Basic (Declaration)
Public Function Set_Sensor_Reflexes ( _
    strBitString As String, _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Set_Sensor_Reflexes (
    string strBitString,
    int timeOut,
    int numRetries
)
C++
public:
String^ Set_Sensor_Reflexes (
    String^ strBitString,
    int timeOut,
    int numRetries
)

Parameters

strBitString (String)
Sensor reflexes bit string. Valid range is 8-bit string of 1's and 0's.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Set_Velocity_PID_Gains Method (Kp, Ki, Kd, timeOut, numRetries)

Set_Velocity_PID_Gains Method (Kp, Ki, Kd, timeOut, numRetries)
CollapseAll image DropDown image

Function to set velocity pid gains.

Syntax

Visual Basic (Declaration)
Public Function Set_Velocity_PID_Gains ( _
    Kp As Integer, _
    Ki As Integer, _
    Kd As Integer, _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Set_Velocity_PID_Gains (
    int Kp,
    int Ki,
    int Kd,
    int timeOut,
    int numRetries
)
C++
public:
String^ Set_Velocity_PID_Gains (
    int Kp,
    int Ki,
    int Kd,
    int timeOut,
    int numRetries
)

Parameters

Kp (Int32)
Proportional gain. Valid range is 0 to 255.
Ki (Int32)
Integral gain. Valid range is 0 to 255.
Kd (Int32)
Derivative gain. Valid range is 0 to 255.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Stop_RFID_Tag_Search Method (timeOut, numRetries)

Stop_RFID_Tag_Search Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to stop searching for in-range RFID tags.

Syntax

Visual Basic (Declaration)
Public Function Stop_RFID_Tag_Search ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Stop_RFID_Tag_Search (
    int timeOut,
    int numRetries
)
C++
public:
String^ Stop_RFID_Tag_Search (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Wander_Mode Method (timeOut, numRetries)

Wander_Mode Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to make robot enter wander mode.

Syntax

Visual Basic (Declaration)
Public Function Wander_Mode ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Wander_Mode (
    int timeOut,
    int numRetries
)
C++
public:
String^ Wander_Mode (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Write_RFID_Data_ASCII Method (strdataRFID, timeOut, numRetries)

Write_RFID_Data_ASCII Method (strdataRFID, timeOut, numRetries)
CollapseAll image DropDown image

Function to write RFID data as ASCII characters.

Syntax

Visual Basic (Declaration)
Public Function Write_RFID_Data_ASCII ( _
    strdataRFID As String, _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Write_RFID_Data_ASCII (
    string strdataRFID,
    int timeOut,
    int numRetries
)
C++
public:
String^ Write_RFID_Data_ASCII (
    String^ strdataRFID,
    int timeOut,
    int numRetries
)

Parameters

strdataRFID (String)
RFID ASCII data. Valid range is 4-characters.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Write_RFID_Data_Hex Method (strdataRFID, timeOut, numRetries)

Write_RFID_Data_Hex Method (strdataRFID, timeOut, numRetries)
CollapseAll image DropDown image

Function to write RFID data as a Hex string.

Syntax

Visual Basic (Declaration)
Public Function Write_RFID_Data_Hex ( _
    strdataRFID As String, _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Write_RFID_Data_Hex (
    string strdataRFID,
    int timeOut,
    int numRetries
)
C++
public:
String^ Write_RFID_Data_Hex (
    String^ strdataRFID,
    int timeOut,
    int numRetries
)

Parameters

strdataRFID (String)
RFID hex data. Valid range is 0 to FFFFFFFF.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


Write_RFID_Data_Integer Method (intdataRFID, timeOut, numRetries)

Write_RFID_Data_Integer Method (intdataRFID, timeOut, numRetries)
CollapseAll image DropDown image

Function to write RFID data as an unsigned integer.

Syntax

Visual Basic (Declaration)
Public Function Write_RFID_Data_Integer ( _
    intdataRFID As Long, _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string Write_RFID_Data_Integer (
    long intdataRFID,
    int timeOut,
    int numRetries
)
C++
public:
String^ Write_RFID_Data_Integer (
    long long intdataRFID,
    int timeOut,
    int numRetries
)

Parameters

intdataRFID (Int64)
RFID unsigned integer. Valid range is 0 to 4294967295.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from ABE board.

Return Value

String. OK is returned when successful, otherwise error is returned.


OPEN_ROBOT_ZigBee_Functions.OPEN_ROBOT_Parameters Structure

OPEN_ROBOT_ZigBee_Functions.OPEN_ROBOT_Parameters Structure
CollapseAll image DropDown image

OPEN_ROBOT Parameter Structure. Contains all OPEN-ROBOT sensors and internal parameters.

Namespace: OPEN_ROBOT_ZigBee_Class_Library
Assembly: OPEN_ROBOT_ZigBee_Functions Version: 1.0.0.0 (OPEN_ROBOT_ZigBee_Functions)

Syntax

Visual Basic (Declaration)
Public Structure OPEN_ROBOT_Parameters
C#
public struct OPEN_ROBOT_Parameters
C++
public value class OPEN_ROBOT_Parameters


adReflexLevel Field

adReflexLevel Field
CollapseAll image DropDown image

AD Reflex Level. Valid range is 0 to 255.

Syntax

Visual Basic (Declaration)
Public adReflexLevel As Byte
C#
public byte adReflexLevel
C++
public:
unsigned char adReflexLevel


BatteryLevel Field

BatteryLevel Field
CollapseAll image DropDown image

Battery Level. Valid range is 0 to 255.

Syntax

Visual Basic (Declaration)
Public BatteryLevel As Byte
C#
public byte BatteryLevel
C++
public:
unsigned char BatteryLevel


bDigitalPins Field

bDigitalPins Field
CollapseAll image DropDown image

Digital IO Pin Readings. Boolean value. True equals pin high and false equals pin low.

Syntax

Visual Basic (Declaration)
Public bDigitalPins As Boolean()
C#
public bool[] bDigitalPins
C++
public:
array<bool>^ bDigitalPins


bMoveComplete Field

bMoveComplete Field
CollapseAll image DropDown image

Move Complete. Boolean value.

Syntax

Visual Basic (Declaration)
Public bMoveComplete As Boolean
C#
public bool bMoveComplete
C++
public:
bool bMoveComplete


bReflexTriggered Field

bReflexTriggered Field
CollapseAll image DropDown image

Sensory Reflex Triggered. Boolean value.

Syntax

Visual Basic (Declaration)
Public bReflexTriggered As Boolean
C#
public bool bReflexTriggered
C++
public:
bool bReflexTriggered


bTagFound Field

bTagFound Field
CollapseAll image DropDown image

RFID Tag Found. True if tag found, otherwise false.

Syntax

Visual Basic (Declaration)
Public bTagFound As Boolean
C#
public bool bTagFound
C++
public:
bool bTagFound


bXBeeCommandModeActive Field

bXBeeCommandModeActive Field
CollapseAll image DropDown image

XBee Command Mode Active. Boolean value. True when XBee Command Mode has been activated.

Syntax

Visual Basic (Declaration)
Public bXBeeCommandModeActive As Boolean
C#
public bool bXBeeCommandModeActive
C++
public:
bool bXBeeCommandModeActive


FCIR Field

FCIR Field
CollapseAll image DropDown image

Front Center IR. Valid range is 0 to 255.

Syntax

Visual Basic (Declaration)
Public FCIR As Byte
C#
public byte FCIR
C++
public:
unsigned char FCIR


FLIR Field

FLIR Field
CollapseAll image DropDown image

Front Left IR. Valid range is 0 to 255.

Syntax

Visual Basic (Declaration)
Public FLIR As Byte
C#
public byte FLIR
C++
public:
unsigned char FLIR


FLL Field

FLL Field
CollapseAll image DropDown image

Front Left Light. Valid range is 0 to 255.

Syntax

Visual Basic (Declaration)
Public FLL As Byte
C#
public byte FLL
C++
public:
unsigned char FLL


FRIR Field

FRIR Field
CollapseAll image DropDown image

Front Right IR. Valid range is 0 to 255.

Syntax

Visual Basic (Declaration)
Public FRIR As Byte
C#
public byte FRIR
C++
public:
unsigned char FRIR


FRL Field

FRL Field
CollapseAll image DropDown image

Front Right Light. Valid range is 0 to 255.

Syntax

Visual Basic (Declaration)
Public FRL As Byte
C#
public byte FRL
C++
public:
unsigned char FRL


int16BitXBeeDestAddressLow Field

int16BitXBeeDestAddressLow Field
CollapseAll image DropDown image

16-Bit XBee Destination Address Low.

Syntax

Visual Basic (Declaration)
Public int16BitXBeeDestAddressLow As Short
C#
public short int16BitXBeeDestAddressLow
C++
public:
short int16BitXBeeDestAddressLow


intRFID Field

intRFID Field
CollapseAll image DropDown image

RFID Integer Reading. Valid range is 0 to 65535.

Syntax

Visual Basic (Declaration)
Public intRFID As Long
C#
public long intRFID
C++
public:
long long intRFID


leftEncoder Field

leftEncoder Field
CollapseAll image DropDown image

Left Encoder Reading. Valid range is 0 to 255.

Syntax

Visual Basic (Declaration)
Public leftEncoder As Integer
C#
public int leftEncoder
C++
public:
int leftEncoder


leftPwmOffset Field

leftPwmOffset Field
CollapseAll image DropDown image

Left PWM Motor Offset.

Syntax

Visual Basic (Declaration)
Public leftPwmOffset As Byte
C#
public byte leftPwmOffset
C++
public:
unsigned char leftPwmOffset


leftWheelVelocity Field

leftWheelVelocity Field
CollapseAll image DropDown image

Left Wheel Velocity. Valid range is -4294967295 to 4294967295.

Syntax

Visual Basic (Declaration)
Public leftWheelVelocity As Short
C#
public short leftWheelVelocity
C++
public:
short leftWheelVelocity


lightReflexLevel Field

lightReflexLevel Field
CollapseAll image DropDown image

Light Reflex Level. Valid range is 0 to 255.

Syntax

Visual Basic (Declaration)
Public lightReflexLevel As Byte
C#
public byte lightReflexLevel
C++
public:
unsigned char lightReflexLevel


pKd Field

pKd Field
CollapseAll image DropDown image

Position Derivative Gain. Valid range is 0 to 255.

Syntax

Visual Basic (Declaration)
Public pKd As Byte
C#
public byte pKd
C++
public:
unsigned char pKd


pKi Field

pKi Field
CollapseAll image DropDown image

Position Integral Gain. Valid range is 0 to 255.

Syntax

Visual Basic (Declaration)
Public pKi As Byte
C#
public byte pKi
C++
public:
unsigned char pKi


pKp Field

pKp Field
CollapseAll image DropDown image

Position Proportional Gain. Valid range is 0 to 255.

Syntax

Visual Basic (Declaration)
Public pKp As Byte
C#
public byte pKp
C++
public:
unsigned char pKp


rightEncoder Field

rightEncoder Field
CollapseAll image DropDown image

Right Encoder Reading. Valid range is -4294967295 to 4294967295.

Syntax

Visual Basic (Declaration)
Public rightEncoder As Integer
C#
public int rightEncoder
C++
public:
int rightEncoder


rightPwmOffset Field

rightPwmOffset Field
CollapseAll image DropDown image

Right PWM Motor Offset.

Syntax

Visual Basic (Declaration)
Public rightPwmOffset As Byte
C#
public byte rightPwmOffset
C++
public:
unsigned char rightPwmOffset


rightWheelVelocity Field

rightWheelVelocity Field
CollapseAll image DropDown image

Right Wheel Velocity. Valid range is -65535 to 65535.

Syntax

Visual Basic (Declaration)
Public rightWheelVelocity As Short
C#
public short rightWheelVelocity
C++
public:
short rightWheelVelocity


RLIR Field

RLIR Field
CollapseAll image DropDown image

Rear Left IR. Valid range is 0 to 255.

Syntax

Visual Basic (Declaration)
Public RLIR As Byte
C#
public byte RLIR
C++
public:
unsigned char RLIR


RRIR Field

RRIR Field
CollapseAll image DropDown image

Rear Right IR. Valid range is 0 to 255.

Syntax

Visual Basic (Declaration)
Public RRIR As Byte
C#
public byte RRIR
C++
public:
unsigned char RRIR


strASCIIRFID Field

strASCIIRFID Field
CollapseAll image DropDown image

RFID ASCII String Reading. Valid range is "xxxx", where x is equal to a valid ASCII character.

Syntax

Visual Basic (Declaration)
Public strASCIIRFID As String
C#
public string strASCIIRFID
C++
public:
String^ strASCIIRFID


strFirmwareInfo Field

strFirmwareInfo Field
CollapseAll image DropDown image

Firmware version information for PIC18F4520.

Syntax

Visual Basic (Declaration)
Public strFirmwareInfo As String
C#
public string strFirmwareInfo
C++
public:
String^ strFirmwareInfo


strHexRFID Field

strHexRFID Field
CollapseAll image DropDown image

RFID Hex String Reading. Valid range is 0x0000 to 0xFFFF.

Syntax

Visual Basic (Declaration)
Public strHexRFID As String
C#
public string strHexRFID
C++
public:
String^ strHexRFID


vKd Field

vKd Field
CollapseAll image DropDown image

Velocity Derivative Gain. Valid range is 0 to 255.

Syntax

Visual Basic (Declaration)
Public vKd As Byte
C#
public byte vKd
C++
public:
unsigned char vKd


vKi Field

vKi Field
CollapseAll image DropDown image

Velocity Integral Gain. Valid range is 0 to 255.

Syntax

Visual Basic (Declaration)
Public vKi As Byte
C#
public byte vKi
C++
public:
unsigned char vKi


vKp Field

vKp Field
CollapseAll image DropDown image

Velocity Proportional Gain. Valid range is 0 to 255.

Syntax

Visual Basic (Declaration)
Public vKp As Byte
C#
public byte vKp
C++
public:
unsigned char vKp


Namespaces
CollapseAll image
OPEN_ROBOT Class Library Namespace. This project was created so that OPEN-ROBOT users can create their own applications using Visual Studio or C# Express. This class library requires a minimum of .NET 2.0.

Namespaces

Namespace | Description
OPEN_ROBOT_ZigBee_Class_Library | [Missing namespace summary documentation for N:OPEN_ROBOT_ZigBee_Class_Library]