OPEN_ROBOT_TCP_Class_Library Namespace

OPEN-ROBOT TCP Functions Documented Class Library
OPEN_ROBOT_TCP_Class_Library Namespace
CollapseAll image
OPEN-ROBOT TCP Class Library Namespace. This project was created so that OPEN-ROBOT users can create their own applications using Visual C# Express. This class library requires a minimum of .NET 2.0.

Classes

Icon | Type | Description
public class | OPEN_ROBOT_TCP_Functions | OPEN_ROBOT TCP-IP Functions Class. Contains all the necessary methods to communicate with OPEN_ROBOT via a MatchPort b/g.

Send comments on this topic to abe@abotics.com

Abe Howell's Robotics.


OPEN_ROBOT_TCP_Functions Class

OPEN_ROBOT_TCP_Functions Class
CollapseAll image DropDown image

OPEN_ROBOT TCP-IP Functions Class. Contains all the necessary methods to communicate with OPEN_ROBOT via a MatchPort b/g.

Namespace: OPEN_ROBOT_TCP_Class_Library
Assembly: OPEN_ROBOT_TCP_Class_Library Version: 1.0.0.0 (OPEN_ROBOT_TCP_Class_Library)

Syntax

Visual Basic (Declaration)
Public Class OPEN_ROBOT_TCP_Functions
C#
public class OPEN_ROBOT_TCP_Functions
C++
public ref class OPEN_ROBOT_TCP_Functions

Inheritance Hierarchy

Object
OPEN_ROBOT_TCP_Class_Library.OPEN_ROBOT_TCP_Functions


OPEN_ROBOT_TCP_Functions Constructor

OPEN_ROBOT_TCP_Functions Constructor
CollapseAll image DropDown image

OPEN_ROBOT_TCP Functions Class Constructor.

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public OPEN_ROBOT_TCP_Functions ()
C++
public:
OPEN_ROBOT_TCP_Functions ()


ClearSocketBuffer Method

ClearSocketBuffer Method
CollapseAll image DropDown image

Function to clear the socket buffer in the event of a read error.

Syntax

Visual Basic (Declaration)
Public Sub ClearSocketBuffer
C#
public void ClearSocketBuffer ()
C++
public:
void ClearSocketBuffer ()


CloseSocketConnection Method

CloseSocketConnection Method
CollapseAll image DropDown image

Function to close the socket connection.

Syntax

Visual Basic (Declaration)
Public Sub CloseSocketConnection
C#
public void CloseSocketConnection ()
C++
public:
void CloseSocketConnection ()


FindRfidTag Method (timeOut, numRetries)

FindRfidTag Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to find in-range RFID tags. Robot will search for in-range tags and stop when a tag is located.

Syntax

Visual Basic (Declaration)
Public Sub FindRfidTag ( _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void FindRfidTag (
    int timeOut,
    int numRetries
)
C++
public:
void FindRfidTag (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


GetAnalogToDigitalSensorReadings Method (timeOut, numRetries)

GetAnalogToDigitalSensorReadings Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to get the Analog to Digital Sensor Readings.

Syntax

Visual Basic (Declaration)
Public Function GetAnalogToDigitalSensorReadings ( _
    timeOut As Integer, _
    numRetries As Integer _
) As Byte()
C#
public byte[] GetAnalogToDigitalSensorReadings (
    int timeOut,
    int numRetries
)
C++
public:
array<unsigned char>^ GetAnalogToDigitalSensorReadings (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read timeout in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.

Return Value

byte[] array containg sensor readings: {battery, FCIR, FLIR, FRIR, RLIR, RRIR, FRL, FLL}.


GetAsciiRfidReading Method (timeOut, numRetries)

GetAsciiRfidReading Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to get RFID Reading as ASCII string.

Syntax

Visual Basic (Declaration)
Public Function GetAsciiRfidReading ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string GetAsciiRfidReading (
    int timeOut,
    int numRetries
)
C++
public:
String^ GetAsciiRfidReading (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.

Return Value

RFID reading as ASCII string.


GetDigitalPinState Method (intPinNum, timeOut, numRetries)

GetDigitalPinState Method (intPinNum, timeOut, numRetries)
CollapseAll image DropDown image

Function to get digital pin's state.

Syntax

Visual Basic (Declaration)
Public Function GetDigitalPinState ( _
    intPinNum As Integer, _
    timeOut As Integer, _
    numRetries As Integer _
) As Boolean
C#
public bool GetDigitalPinState (
    int intPinNum,
    int timeOut,
    int numRetries
)
C++
public:
bool GetDigitalPinState (
    int intPinNum,
    int timeOut,
    int numRetries
)

Parameters

intPinNum (Int32)
Pin number. Valid range is 0 to 7.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.

Return Value

Pin State as boolean.


GetFirmwareVersion Method (timeOut, numRetries)

GetFirmwareVersion Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to get firmware version for the PIC18F4520.

Syntax

Visual Basic (Declaration)
Public Function GetFirmwareVersion ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string GetFirmwareVersion (
    int timeOut,
    int numRetries
)
C++
public:
String^ GetFirmwareVersion (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.

Return Value

String containing firmware version or empty string for an error.


GetHexRfidReading Method (timeOut, numRetries)

GetHexRfidReading Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to get RFID Reading as Hex string.

Syntax

Visual Basic (Declaration)
Public Function GetHexRfidReading ( _
    timeOut As Integer, _
    numRetries As Integer _
) As String
C#
public string GetHexRfidReading (
    int timeOut,
    int numRetries
)
C++
public:
String^ GetHexRfidReading (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.

Return Value

RFID reading as Hex string.


GetIntegerRfidReading Method (timeOut, numRetries)

GetIntegerRfidReading Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to get RFID Reading as a long value.

Syntax

Visual Basic (Declaration)
Public Function GetIntegerRfidReading ( _
    timeOut As Integer, _
    numRetries As Integer _
) As Long
C#
public long GetIntegerRfidReading (
    int timeOut,
    int numRetries
)
C++
public:
long long GetIntegerRfidReading (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.

Return Value

RFID reading as a long value.


GetJpegImage Method (timeOutMS)

GetJpegImage Method (timeOutMS)
CollapseAll image DropDown image

Function to Get JPEG Image from SRV1 Camera.

Syntax

Visual Basic (Declaration)
Public Function GetJpegImage ( _
    timeOutMS As Integer _
) As Byte()
C#
public byte[] GetJpegImage (
    int timeOutMS
)
C++
public:
array<unsigned char>^ GetJpegImage (
    int timeOutMS
)

Parameters

timeOutMS (Int32)
Read timeout in milliseconds.

Return Value

Returns byte array of camera data if successful, otherwise returns a byte array of lenght 0.


GetPositionGainsPID Method (timeOut, numRetries)

GetPositionGainsPID Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to get the position PID gains.

Syntax

Visual Basic (Declaration)
Public Function GetPositionGainsPID ( _
    timeOut As Integer, _
    numRetries As Integer _
) As Byte()
C#
public byte[] GetPositionGainsPID (
    int timeOut,
    int numRetries
)
C++
public:
array<unsigned char>^ GetPositionGainsPID (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.

Return Value

Byte[] array containing position PID gains: {Kp, Ki, Kd}.


GetPwmOffsets Method (timeOut, numRetries)

GetPwmOffsets Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to refresh the Left and Right PWM Motor Offset Parameters.

Syntax

Visual Basic (Declaration)
Public Function GetPwmOffsets ( _
    timeOut As Integer, _
    numRetries As Integer _
) As Byte()
C#
public byte[] GetPwmOffsets (
    int timeOut,
    int numRetries
)
C++
public:
array<unsigned char>^ GetPwmOffsets (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.

Return Value

Byte[] array containg PWM offsets: {left PWM offset, right PWM offset}.


GetReflexLevels Method (timeOut, numRetries)

GetReflexLevels Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to refresh ad/light sensor reflex level.

Syntax

Visual Basic (Declaration)
Public Function GetReflexLevels ( _
    timeOut As Integer, _
    numRetries As Integer _
) As Byte()
C#
public byte[] GetReflexLevels (
    int timeOut,
    int numRetries
)
C++
public:
array<unsigned char>^ GetReflexLevels (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.

Return Value

Byte[] array containg relfex levels: {AD reflex level, Light reflex level}.


GetSocketDataBytes Method

GetSocketDataBytes Method
CollapseAll image

Members

Icon | Member | Description
 | GetSocketDataBytes(Int32, Char) | Function to read incoming socket data and return as byte array.
 | GetSocketDataBytes(Int32, Int32) | Function to read incoming socket data and return as byte array.


GetSocketDataBytes Method (timeOutMS, terminatingChar)

GetSocketDataBytes Method (timeOutMS, terminatingChar)
CollapseAll image DropDown image

Function to read incoming socket data and return as byte array.

Syntax

Visual Basic (Declaration)
Public Function GetSocketDataBytes ( _
    timeOutMS As Integer, _
    terminatingChar As Char _
) As Byte()
C#
public byte[] GetSocketDataBytes (
    int timeOutMS,
    char terminatingChar
)
C++
public:
array<unsigned char>^ GetSocketDataBytes (
    int timeOutMS,
    wchar_t terminatingChar
)

Parameters

timeOutMS (Int32)

[Missing <param> documentation for "timeOutMS"]

terminatingChar (Char)

[Missing <param> documentation for "terminatingChar"]

Return Value

Returns byte array with socket data if success, otherwise returns byte array of length 0.


GetSocketDataBytes Method (timeOutMS, numBytes)

GetSocketDataBytes Method (timeOutMS, numBytes)
CollapseAll image DropDown image

Function to read incoming socket data and return as byte array.

Syntax

Visual Basic (Declaration)
Public Function GetSocketDataBytes ( _
    timeOutMS As Integer, _
    numBytes As Integer _
) As Byte()
C#
public byte[] GetSocketDataBytes (
    int timeOutMS,
    int numBytes
)
C++
public:
array<unsigned char>^ GetSocketDataBytes (
    int timeOutMS,
    int numBytes
)

Parameters

timeOutMS (Int32)

[Missing <param> documentation for "timeOutMS"]

numBytes (Int32)

[Missing <param> documentation for "numBytes"]

Return Value

Returns byte array with socket data if success, otherwise returns byte array of length 0.


GetVelocityGainsPID Method (timeOut, numRetries)

GetVelocityGainsPID Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to refresh the velocity pid gains.

Syntax

Visual Basic (Declaration)
Public Function GetVelocityGainsPID ( _
    timeOut As Integer, _
    numRetries As Integer _
) As Byte()
C#
public byte[] GetVelocityGainsPID (
    int timeOut,
    int numRetries
)
C++
public:
array<unsigned char>^ GetVelocityGainsPID (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.

Return Value

Byte[] array containing velocity PID gains: {Kp, Ki, Kd}.


GetWheelEncoderReadings Method (timeOut, numRetries)

GetWheelEncoderReadings Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to refresh the wheel encoder readings.

Syntax

Visual Basic (Declaration)
Public Function GetWheelEncoderReadings ( _
    timeOut As Integer, _
    numRetries As Integer _
) As Integer()
C#
public int[] GetWheelEncoderReadings (
    int timeOut,
    int numRetries
)
C++
public:
array<int>^ GetWheelEncoderReadings (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.

Return Value

int[] array containg left and right encoder readings: {left encoder reading, right encoder reading}.


GetWheelVelocities Method (timeOut, numRetries)

GetWheelVelocities Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to get the wheel velocity readings.

Syntax

Visual Basic (Declaration)
Public Function GetWheelVelocities ( _
    timeOut As Integer, _
    numRetries As Integer _
) As Integer()
C#
public int[] GetWheelVelocities (
    int timeOut,
    int numRetries
)
C++
public:
array<int>^ GetWheelVelocities (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.

Return Value

Int[] array containing wheel velocities: {left wheel velocity, right wheel velocity}.


IsMoveComplete Method (timeOut, numRetries)

IsMoveComplete Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to refresh move complete.

Syntax

Visual Basic (Declaration)
Public Function IsMoveComplete ( _
    timeOut As Integer, _
    numRetries As Integer _
) As Boolean
C#
public bool IsMoveComplete (
    int timeOut,
    int numRetries
)
C++
public:
bool IsMoveComplete (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.

Return Value

True if move complete or false if robot is still in motion.


IsReflexTriggered Method (timeOut, numRetries)

IsReflexTriggered Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to dtermine if reflex has been triggered.

Syntax

Visual Basic (Declaration)
Public Function IsReflexTriggered ( _
    timeOut As Integer, _
    numRetries As Integer _
) As Boolean
C#
public bool IsReflexTriggered (
    int timeOut,
    int numRetries
)
C++
public:
bool IsReflexTriggered (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.

Return Value

True if reflex has been triggered, otherwise false.


IsRfidTagFound Method (timeOut, numRetries)

IsRfidTagFound Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to Update RFID Tag Found. Used in conjunction with Find_RFID_Tag function. Checks to see if a tag has been located.

Syntax

Visual Basic (Declaration)
Public Function IsRfidTagFound ( _
    timeOut As Integer, _
    numRetries As Integer _
) As Boolean
C#
public bool IsRfidTagFound (
    int timeOut,
    int numRetries
)
C++
public:
bool IsRfidTagFound (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.

Return Value

True if tag found, otherwise false.


MoveToPosition Method (leftWheel, rightWheel, timeOut, numRetries)

MoveToPosition Method (leftWheel, rightWheel, timeOut, numRetries)
CollapseAll image DropDown image

Function to move robot using position control.

Syntax

Visual Basic (Declaration)
Public Sub MoveToPosition ( _
    leftWheel As Integer, _
    rightWheel As Integer, _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void MoveToPosition (
    int leftWheel,
    int rightWheel,
    int timeOut,
    int numRetries
)
C++
public:
void MoveToPosition (
    int leftWheel,
    int rightWheel,
    int timeOut,
    int numRetries
)

Parameters

leftWheel (Int32)
Number of left wheel encoder ticks. Valid range is -500 to 500.
rightWheel (Int32)
Number of right wheel encoder ticks. Valid range is -500 to 500.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


OpenSocketConnection Method (ipAddress, portNumber)

OpenSocketConnection Method (ipAddress, portNumber)
CollapseAll image DropDown image

Function to open a socket connection with the OPEN_ROBOT's MatchPort.

Syntax

Visual Basic (Declaration)
Public Sub OpenSocketConnection ( _
    ipAddress As String, _
    portNumber As Integer _
)
C#
public void OpenSocketConnection (
    string ipAddress,
    int portNumber
)
C++
public:
void OpenSocketConnection (
    String^ ipAddress,
    int portNumber
)

Parameters

ipAddress (String)
IP Address of the Robot's MatchPort.
portNumber (Int32)
Port number for Serial Port#1 on MatchPort is 10001.


ResetRfidModule Method (timeOut, numRetries)

ResetRfidModule Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to reset the RFID module.

Syntax

Visual Basic (Declaration)
Public Sub ResetRfidModule ( _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void ResetRfidModule (
    int timeOut,
    int numRetries
)
C++
public:
void ResetRfidModule (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


ResetSensorReflexTrigger Method (timeOut, numRetries)

ResetSensorReflexTrigger Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to reset sensor reflex trigger.

Syntax

Visual Basic (Declaration)
Public Sub ResetSensorReflexTrigger ( _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void ResetSensorReflexTrigger (
    int timeOut,
    int numRetries
)
C++
public:
void ResetSensorReflexTrigger (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


SaveParametersToEEPROM Method (timeOut, numRetries)

SaveParametersToEEPROM Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to save OPEN-ROBOT parameters to EEPROM.

Syntax

Visual Basic (Declaration)
Public Sub SaveParametersToEEPROM ( _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void SaveParametersToEEPROM (
    int timeOut,
    int numRetries
)
C++
public:
void SaveParametersToEEPROM (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


SendSocketData Method (socketData, useTerminatingChar, terminatingChar)

SendSocketData Method (socketData, useTerminatingChar, terminatingChar)
CollapseAll image DropDown image

Function to send socket data to OPEN-ROBOT's MatchPort.

Syntax

Visual Basic (Declaration)
Public Sub SendSocketData ( _
    socketData As String, _
    useTerminatingChar As Boolean, _
    terminatingChar As Char _
)
C#
public void SendSocketData (
    string socketData,
    bool useTerminatingChar,
    char terminatingChar
)
C++
public:
void SendSocketData (
    String^ socketData,
    bool useTerminatingChar,
    wchar_t terminatingChar
)

Parameters

socketData (String)

[Missing <param> documentation for "socketData"]

useTerminatingChar (Boolean)

[Missing <param> documentation for "useTerminatingChar"]

terminatingChar (Char)

[Missing <param> documentation for "terminatingChar"]


SetAnalogToDigitalReflexLevel Method (reflexLevel, timeOut, numRetries)

SetAnalogToDigitalReflexLevel Method (reflexLevel, timeOut, numRetries)
CollapseAll image DropDown image

Function to set the Analog to Digital reflex level.

Syntax

Visual Basic (Declaration)
Public Sub SetAnalogToDigitalReflexLevel ( _
    reflexLevel As Integer, _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void SetAnalogToDigitalReflexLevel (
    int reflexLevel,
    int timeOut,
    int numRetries
)
C++
public:
void SetAnalogToDigitalReflexLevel (
    int reflexLevel,
    int timeOut,
    int numRetries
)

Parameters

reflexLevel (Int32)
AD reflex level. Valid range is 0 to 255.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


SetClosedLoopVelocity Method (leftWheelVelocity, rightWheelVelocity, timeOut, numRetries)

SetClosedLoopVelocity Method (leftWheelVelocity, rightWheelVelocity, timeOut, numRetries)
CollapseAll image DropDown image

Function to set Closed loop wheel velocity.

Syntax

Visual Basic (Declaration)
Public Sub SetClosedLoopVelocity ( _
    leftWheelVelocity As Integer, _
    rightWheelVelocity As Integer, _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void SetClosedLoopVelocity (
    int leftWheelVelocity,
    int rightWheelVelocity,
    int timeOut,
    int numRetries
)
C++
public:
void SetClosedLoopVelocity (
    int leftWheelVelocity,
    int rightWheelVelocity,
    int timeOut,
    int numRetries
)

Parameters

leftWheelVelocity (Int32)
Left wheel velocity. Valid range is -60 to 60 tenths of an inch per second.
rightWheelVelocity (Int32)
Right wheel velocity. Valid range is -60 to 60 tenths of an inch per second.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


SetDigitalPinState Method (pinNum, pinState, timeOut, numRetries)

SetDigitalPinState Method (pinNum, pinState, timeOut, numRetries)
CollapseAll image DropDown image

Function to set digital pin high.

Syntax

Visual Basic (Declaration)
Public Sub SetDigitalPinState ( _
    pinNum As Integer, _
    pinState As Boolean, _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void SetDigitalPinState (
    int pinNum,
    bool pinState,
    int timeOut,
    int numRetries
)
C++
public:
void SetDigitalPinState (
    int pinNum,
    bool pinState,
    int timeOut,
    int numRetries
)

Parameters

pinNum (Int32)
Digital pin number. Valid range is 0 to 7.
pinState (Boolean)
State of pin: true = high and false = low.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


SetJpegQuality Method (qualityLevel, timeOutMS)

SetJpegQuality Method (qualityLevel, timeOutMS)
CollapseAll image DropDown image

Function to set the JPEG QUality for the SRV1 Camera.

Syntax

Visual Basic (Declaration)
Public Sub SetJpegQuality ( _
    qualityLevel As Integer, _
    timeOutMS As Integer _
)
C#
public void SetJpegQuality (
    int qualityLevel,
    int timeOutMS
)
C++
public:
void SetJpegQuality (
    int qualityLevel,
    int timeOutMS
)

Parameters

qualityLevel (Int32)
Quality level of SRV1 JPEG images.
timeOutMS (Int32)
Read time out in milliseconds.


SetLightReflexLevel Method (reflexLevel, timeOut, numRetries)

SetLightReflexLevel Method (reflexLevel, timeOut, numRetries)
CollapseAll image DropDown image

Function to set light reflex level.

Syntax

Visual Basic (Declaration)
Public Sub SetLightReflexLevel ( _
    reflexLevel As Integer, _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void SetLightReflexLevel (
    int reflexLevel,
    int timeOut,
    int numRetries
)
C++
public:
void SetLightReflexLevel (
    int reflexLevel,
    int timeOut,
    int numRetries
)

Parameters

reflexLevel (Int32)
Light reflex level. Valid range is 0 to 255.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


SetOpenLoopVelocity Method (leftWheelVelocity, rightWheelVelocity, timeOut, numRetries)

SetOpenLoopVelocity Method (leftWheelVelocity, rightWheelVelocity, timeOut, numRetries)
CollapseAll image DropDown image

Function to set open loop wheel velocity.

Syntax

Visual Basic (Declaration)
Public Sub SetOpenLoopVelocity ( _
    leftWheelVelocity As Integer, _
    rightWheelVelocity As Integer, _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void SetOpenLoopVelocity (
    int leftWheelVelocity,
    int rightWheelVelocity,
    int timeOut,
    int numRetries
)
C++
public:
void SetOpenLoopVelocity (
    int leftWheelVelocity,
    int rightWheelVelocity,
    int timeOut,
    int numRetries
)

Parameters

leftWheelVelocity (Int32)
Left wheel velocity. Valid range is -60 to 60.
rightWheelVelocity (Int32)
Right wheel velocity. Valid range is -60 to 60.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


SetPositionGainsPID Method (Kp, Ki, Kd, timeOut, numRetries)

SetPositionGainsPID Method (Kp, Ki, Kd, timeOut, numRetries)
CollapseAll image DropDown image

Function to set the position pid gains.

Syntax

Visual Basic (Declaration)
Public Sub SetPositionGainsPID ( _
    Kp As Integer, _
    Ki As Integer, _
    Kd As Integer, _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void SetPositionGainsPID (
    int Kp,
    int Ki,
    int Kd,
    int timeOut,
    int numRetries
)
C++
public:
void SetPositionGainsPID (
    int Kp,
    int Ki,
    int Kd,
    int timeOut,
    int numRetries
)

Parameters

Kp (Int32)
Proportional gain. Valid range is 0 to 255.
Ki (Int32)
Integral gain. Valid range is 0 to 255.
Kd (Int32)
Derivative gain. Valid range is 0 to 255.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


SetPwmOffset Method (pwm_offset, leftWheel, timeOut, numRetries)

SetPwmOffset Method (pwm_offset, leftWheel, timeOut, numRetries)
CollapseAll image DropDown image

Function to set the PWM Motor Offset.

Syntax

Visual Basic (Declaration)
Public Sub SetPwmOffset ( _
    pwm_offset As Integer, _
    leftWheel As Boolean, _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void SetPwmOffset (
    int pwm_offset,
    bool leftWheel,
    int timeOut,
    int numRetries
)
C++
public:
void SetPwmOffset (
    int pwm_offset,
    bool leftWheel,
    int timeOut,
    int numRetries
)

Parameters

pwm_offset (Int32)
PWM Motor Offset Parameter.
leftWheel (Boolean)
Set to true to adjust left wheel pwm, otherwise false for the right wheel.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


SetSensorReflexes Method (strBitString, timeOut, numRetries)

SetSensorReflexes Method (strBitString, timeOut, numRetries)
CollapseAll image DropDown image

Function to set sensor reflexes.

Syntax

Visual Basic (Declaration)
Public Sub SetSensorReflexes ( _
    strBitString As String, _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void SetSensorReflexes (
    string strBitString,
    int timeOut,
    int numRetries
)
C++
public:
void SetSensorReflexes (
    String^ strBitString,
    int timeOut,
    int numRetries
)

Parameters

strBitString (String)
Sensor reflexes bit string. Valid range is 8-bit string of 1's and 0's.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


SetSRV1CameraConnectionStatus Method (isSRV1CameraConnected)

SetSRV1CameraConnectionStatus Method (isSRV1CameraConnected)
CollapseAll image DropDown image

Function to set SRV1 Camera connection status.

Syntax

Visual Basic (Declaration)
Public Sub SetSRV1CameraConnectionStatus ( _
    isSRV1CameraConnected As Boolean _
)
C#
public void SetSRV1CameraConnectionStatus (
    bool isSRV1CameraConnected
)
C++
public:
void SetSRV1CameraConnectionStatus (
    bool isSRV1CameraConnected
)

Parameters

isSRV1CameraConnected (Boolean)
If SRV1 Camera is connected to OPEN-ROBOT set to TRUE, else default is False.


SetSRV1CameraResolution Method (cameraResolution, timeOutMS)

SetSRV1CameraResolution Method (cameraResolution, timeOutMS)
CollapseAll image DropDown image

Function to Set the SRV1 Camera Resolution.

Syntax

Visual Basic (Declaration)
Public Sub SetSRV1CameraResolution ( _
    cameraResolution As String, _
    timeOutMS As Integer _
)
C#
public void SetSRV1CameraResolution (
    string cameraResolution,
    int timeOutMS
)
C++
public:
void SetSRV1CameraResolution (
    String^ cameraResolution,
    int timeOutMS
)

Parameters

cameraResolution (String)

[Missing <param> documentation for "cameraResolution"]

timeOutMS (Int32)
Read time out in milliseconds.


SetVelocityGainsPID Method (Kp, Ki, Kd, timeOut, numRetries)

SetVelocityGainsPID Method (Kp, Ki, Kd, timeOut, numRetries)
CollapseAll image DropDown image

Function to set velocity pid gains.

Syntax

Visual Basic (Declaration)
Public Sub SetVelocityGainsPID ( _
    Kp As Integer, _
    Ki As Integer, _
    Kd As Integer, _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void SetVelocityGainsPID (
    int Kp,
    int Ki,
    int Kd,
    int timeOut,
    int numRetries
)
C++
public:
void SetVelocityGainsPID (
    int Kp,
    int Ki,
    int Kd,
    int timeOut,
    int numRetries
)

Parameters

Kp (Int32)
Proportional gain. Valid range is 0 to 255.
Ki (Int32)
Integral gain. Valid range is 0 to 255.
Kd (Int32)
Derivative gain. Valid range is 0 to 255.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


socketOpen Field

socketOpen Field
CollapseAll image DropDown image

State variable for Socket State.

Syntax

Visual Basic (Declaration)
Public socketOpen As Boolean
C#
public bool socketOpen
C++
public:
bool socketOpen


StartWanderMode Method (timeOut, numRetries)

StartWanderMode Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to make robot enter wander mode and drive to avoid obstacles.

Syntax

Visual Basic (Declaration)
Public Sub StartWanderMode ( _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void StartWanderMode (
    int timeOut,
    int numRetries
)
C++
public:
void StartWanderMode (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


StopRfidTagSearch Method (timeOut, numRetries)

StopRfidTagSearch Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to stop searching for in-range RFID tags.

Syntax

Visual Basic (Declaration)
Public Sub StopRfidTagSearch ( _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void StopRfidTagSearch (
    int timeOut,
    int numRetries
)
C++
public:
void StopRfidTagSearch (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


StopRobot Method (timeOut, numRetries)

StopRobot Method (timeOut, numRetries)
CollapseAll image DropDown image

Function to stop the agent immediately.

Syntax

Visual Basic (Declaration)
Public Sub StopRobot ( _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void StopRobot (
    int timeOut,
    int numRetries
)
C++
public:
void StopRobot (
    int timeOut,
    int numRetries
)

Parameters

timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


WriteRfidDataASCII Method (dataRFID, timeOut, numRetries)

WriteRfidDataASCII Method (dataRFID, timeOut, numRetries)
CollapseAll image DropDown image

Function to write RFID data as ASCII characters.

Syntax

Visual Basic (Declaration)
Public Sub WriteRfidDataASCII ( _
    dataRFID As String, _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void WriteRfidDataASCII (
    string dataRFID,
    int timeOut,
    int numRetries
)
C++
public:
void WriteRfidDataASCII (
    String^ dataRFID,
    int timeOut,
    int numRetries
)

Parameters

dataRFID (String)
RFID ASCII data. Valid range is 4-characters.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


WriteRFIDDataHex Method (strdataRFID, timeOut, numRetries)

WriteRFIDDataHex Method (strdataRFID, timeOut, numRetries)
CollapseAll image DropDown image

Function to write RFID data as a Hex string.

Syntax

Visual Basic (Declaration)
Public Sub WriteRFIDDataHex ( _
    strdataRFID As String, _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void WriteRFIDDataHex (
    string strdataRFID,
    int timeOut,
    int numRetries
)
C++
public:
void WriteRFIDDataHex (
    String^ strdataRFID,
    int timeOut,
    int numRetries
)

Parameters

strdataRFID (String)
RFID hex data. Valid range is 0 to FFFFFFFF.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


WriteRfidDataInteger Method (intdataRFID, timeOut, numRetries)

WriteRfidDataInteger Method (intdataRFID, timeOut, numRetries)
CollapseAll image DropDown image

Function to write RFID data as an unsigned integer.

Syntax

Visual Basic (Declaration)
Public Sub WriteRfidDataInteger ( _
    intdataRFID As Long, _
    timeOut As Integer, _
    numRetries As Integer _
)
C#
public void WriteRfidDataInteger (
    long intdataRFID,
    int timeOut,
    int numRetries
)
C++
public:
void WriteRfidDataInteger (
    long long intdataRFID,
    int timeOut,
    int numRetries
)

Parameters

intdataRFID (Int64)
RFID unsigned integer. Valid range is 0 to 4294967295.
timeOut (Int32)
Read time out in milliseconds.
numRetries (Int32)
Number of times to resend if no acknowledge from OPEN-ROBOT board.


Namespaces
CollapseAll image
This project was created so that OPEN-ROBOT users can create their own applications using Visual C# Express. This class library requires a minimum of .NET 2.0.

Namespaces

Namespace | Description
OPEN_ROBOT_TCP_Class_Library | OPEN-ROBOT TCP Class Library Namespace. This project was created so that OPEN-ROBOT users can create their own applications using Visual C# Express. This class library requires a minimum of .NET 2.0.